X-Rite photo
Follow Us:
Blog
YouTube
facebook
twitter
Instagram
LinkedIn



Sign Up   |    My X-Rite   

Date Created: 8/14/2006   Date Modified: 5/25/2016

-PM5 Support for the Intel Mac

Question:  Can I run the PM5 software on my new MacBook with Intel processor and Mac OSX 10.4.6?

Answer:  Yes, you can. PM v5.0.7 and above are compatible with the new Intel Macs. With Mac OSX 10.4.6 or higher, please download the latest software from the following location:


http://www.xrite.com/product_overview.aspx?Industry=1&Segment=10&ID=757&Action=Support